Back to overview
Downtime

AlbaHost, Albania is down

Nov 19 at 05:33pm IST
Affected services
AlbaHost, Albania

Resolved
Nov 19 at 07:38pm IST

AlbaHost, Albania recovered.

Created
Nov 19 at 05:33pm IST

AlbaHost, Albania went down due to power outage.

https://status.albahost.net/cm3ofj49y000a10ob1ybm3w6l